Lifecycle Technology | Support Portal

Oracle Java Certificates Expired - Replace AutoVue JAR's (Tomcat)


Getting Started

To begin you will need to  download the latest AutoVue Jar Updater application which you can find here. You will need a password to download the updater which you should have already received from Lifecycle Technology. If you have not received your password from Lifecycle Technology please email

Standard use 

1. Copy Autovue.Jar.Updater.V1.0.jar to your Tomcat web apps folder e.g.

C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps    2.Double-click Autovue.Jar.Updater.V1.0.jar to run the program. The program will search for valid JAR files to update, and display their paths on screen 

2. Double-click Autovue.Jar.Updater.V1.0.jar to run the program. 
The program will search for valid JAR files to update, and display their paths on screen 

3. If you are happy with the JARs in the list, click OK to start the process. Otherwise, close the window. 

4. Once finished, you may click OK to close the window. 

5. You will need to restart the Apache Tomcat service to pick up the changes. Open up the Services application (you can find this by typing services into the Start menu search), right-click Apache Tomcat Server and click Restart

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request


  • Avatar
    Drew McPayne

    If the message displayed in step 4 shows something like;

    Updating \html\jvue.jar
    Reverting D:\Oracle\AutoVue\html\jvue.jar
    Cleaning up...
    Update failed on 27 of 27 JARs.
    Please raise a support request and attach the log file.

    This will be a permission issue to run the app.

    Please open a command prompt 'As Administrator', navigate to the folder where the jar is stored and run via the command prompt -> this resolves any permission issues :)

  • Avatar
    Drew McPayne

    For anyone that is still running Java JRE 6.X

    You will receive the following error;
    Could not find the main class: com.lct.jarresigner.JarUI.Program will exit.

    Please update the JRE on the server to JRE 8 to run this app
    You can download the JRE here;

    Please contact our support system if you are still having issues :)